Consumers in Australia and New Zealand are not able to see their open invoices from the "Payments" page in Klarna App
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Oct 11, 2021 - 07:12 CEST
Investigating
Consumers can't see their open invoices under the "Payments" page in the app. This is affecting 25% of requests. We are currently investigating the issue.
Posted Oct 11, 2021 - 06:36 CEST
This incident affected: Klarna App.