~50% of consumers in Italy might be declined from purchasing with Pay Later payment method due to an issue with credit assessments
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Jun 13, 2021 - 15:05 CEST
Monitoring
We are currently seeing the conversion rates recovering. We will continue to monitor closely.
Posted Jun 13, 2021 - 14:27 CEST
Investigating
We are experiencing issues with receiving credit assessments from our third-party bureau resulting in a higher number of consumers being declined credit than we would ordinarily expect. This may be reflected in a lower conversion rate for merchants with an Italian consumer base.
Posted Jun 13, 2021 - 12:14 CEST