Disruption to Klarna Online and invoice availability
Incident Report for Klarna
Resolved
Our engineers have resolved this problem and normal service is resumed. We thank you for your patience and apologize for the inconvenience caused. If you encounter any further trouble in relation to Klarna Online, please reach out to your technical account manager for further assistance.
Posted Jul 07, 2020 - 08:23 CEST
Investigating
Klarna Online is currently unavailable and consumers are currently unable to download invoices from the Klarna app or website. We are investigating these problems and apologize for any inconvenience caused.
Posted Jul 07, 2020 - 07:48 CEST
This incident affected: Klarna App and Klarna Online.