Degradation in performance for Klarna Payments through PayBright in Canada
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Jul 17, 2021 - 01:52 CEST
Investigating
Klarna payments in Canada through PayBright is experiencing a degradation in performance. We are currently investigating the situation.
Posted Jul 17, 2021 - 01:29 CEST
This incident affected: Klarna Payments (KP).