Delayed payouts for some UK merchants
Incident Report for Klarna
Resolved
This incident has been resolved. The affected merchants can expect to receive settlement for the past two days alongside settlement for today’s captured purchases.
We thank you for your patience and apologize for the inconvenience caused.
Posted Nov 25, 2020 - 13:39 CET
Identified
Some merchants based in the UK might experience a two days delay to their payouts. This is due to an identified technical problem with a provider which is currently being remediated. We apologize for the delay and thank you for your patience.
Posted Nov 25, 2020 - 10:38 CET