Settlements degradation for Finland
Incident Report for Klarna
Resolved
Thank you for your patience, the issue has been resolved.
Posted Dec 21, 2023 - 09:16 CET
Update
We are continuing to work on a fix for this issue. Apologies for any inconvenience.
Posted Dec 19, 2023 - 16:51 CET
Update
We are continuing to work on a fix for this issue. Apologies for any inconvenience.
Posted Dec 19, 2023 - 16:50 CET
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 12, 2023 - 11:01 CET
Update
We are continuing to investigate this issue.
Posted Dec 12, 2023 - 11:00 CET
Investigating
The pay in part option for invoice in Finland is not showing for all customers. Issue has been identified and a fix is being implemented. Apologies for any inconvenience.
Posted Dec 08, 2023 - 15:36 CET
This incident affected: Klarna App (Europe).