Klarna Card degradation in the EU
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Apr 26, 2022 - 10:55 CEST
Monitoring
The issue seems to be improving after 10:20 CEST. We are monitoring the situation to confirm that services are back to normal.
Posted Apr 26, 2022 - 10:30 CEST
Identified
The 3rd party has acknowledged the issue and is working on it.
Posted Apr 26, 2022 - 10:21 CEST
Investigating
We are currently experiencing issues with Klarna Card in the EU due to issues at a 3rd party provider. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Apr 26, 2022 - 09:21 CEST
This incident affected: Klarna Card (Europe).