Disruption to Klarna Payments in the EU
Incident Report for Klarna
Resolved
We have identified and addressed the cause of this issue and we have verified that it is now resolved. This incident affected 92 sessions between 11:40 - 12:13 (CET).
We apologize for any inconvenience caused.
Posted Dec 03, 2020 - 12:56 CET
Investigating
Some consumers in the EU who are opting to pay later are currently unable to complete their orders. We are investigating the cause of this problem and will provide further updates in due course.
Posted Dec 03, 2020 - 12:36 CET
This incident affected: Klarna Payments (KP).