New users unable to log in to Merchant Portal
Incident Report for Klarna
Resolved
The issue has now been resolved. If you are still affected, please contact merchant support. We are sorry for the inconvenience caused.
Posted Apr 28, 2020 - 17:15 CEST
Update
All users and groups created during this incident has been restored. Affected users have until midnight to re-activate their accounts, after that you will have to contact Merchant Support for a one time password.
Posted Apr 23, 2020 - 14:07 CEST
Investigating
Users created for the Merchant Portal since Thursday April 16 may currently experience difficulties logging in. Users may follow the 'Forgot your password?' link on the Merchant Portal login screen to set a new password for their account and restore access.

Some merchants may also need to reassociate users. This can be performed by the designated merchant administrator within the Merchant Portal. Please note that some designated merchant administrators may themselves be unable to login at this time. We are working to restore this access as soon as possible and we apologize for the inconvenience caused.
Posted Apr 21, 2020 - 12:02 CEST
This incident affected: Merchant Portal.