Issue with Merchant portal
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted 6 days ago. Sep 11, 2019 - 16:19 CEST
Monitoring
The service returned to normal. We will continue monitoring the system.
Posted 6 days ago. Sep 11, 2019 - 14:48 CEST
Investigating
Merchant portal is currently not available. Our engineering is working on it. We are sorry for the inconvenience. We will update as soon as we get more information.
Posted 6 days ago. Sep 11, 2019 - 14:45 CEST
This incident affected: Merchant Portal.