We see a 10% drop in conversion in the Netherlands since yesterday
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Oct 07, 2021 - 12:59 CEST
Investigating
Due to a recent change, some consumers in the Netherlands might have issues authenticating their purchase. We are currently investigating.
Posted Oct 06, 2021 - 12:11 CEST
This incident affected: Klarna Checkout (KCO) and Klarna Payments (KP).