Customer service phone numbers in Denmark and Finland unavailable
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Sep 28, 2021 - 11:42 CEST
Update
We are continuing to investigate this issue.
Posted Sep 28, 2021 - 10:34 CEST
Investigating
Customer service phone numbers in Denmark and Finland are unavailable. Chat is open, so both end-consumers and merchants can reach us that way.
Posted Sep 28, 2021 - 08:36 CEST
This incident affected: Customer Service.