Payment delayed for a Subset of merchants in the EU
Incident Report for Klarna
Resolved
The issue has been fixed throughout the day and we are sorry for the delay of payments for affected merchants.
Posted Jun 29, 2020 - 17:27 CEST
Identified
Due to an issue, payments for a subset of merchants operating in the EU region have been delayed. The issue has been resolved and all late payments since Wednesday June 24th will be processed on Monday. We are sorry for the inconvenience caused.
Posted Jun 26, 2020 - 18:17 CEST
This incident affected: Merchant Portal.