Consumers in the UK cannot currently pay with Direct Debit
Incident Report for Klarna
Resolved
We have verified that this problem is now resolved. This incident affected UK Direct Debit payment attempts made between 16:55 - 17:21 (BST). We apologize for any inconvenience caused during this time.
Posted Sep 02, 2020 - 18:36 CEST
Investigating
Consumers in the UK are currently unable to make payments using Direct Debit. This may affect the conversion rate for merchants accepting orders from UK consumers who opt to pay immediately with Direct Debit through Klarna Checkout.
Posted Sep 02, 2020 - 18:25 CEST
This incident affected: Klarna App and Klarna Checkout (KCO).