Merchant onboarding system degradation
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Oct 03, 2024 - 07:30 CEST
Investigating
We are currently experiencing issues with the merchant onboarding process in North America. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Oct 03, 2024 - 06:01 CEST
This incident affected: Merchant Onboarding (North America).