Klarna In-Store Digital Card - US
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Nov 09, 2023 - 08:52 CET
Update
Earlier this update mentioned that Klarna Virtual Card was impacted. This is not the case. We are continuing to work on restoring service as soon as possible. Thank you for your patience.
Posted Nov 09, 2023 - 03:27 CET
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 09, 2023 - 02:46 CET
Investigating
We are currently experiencing issues with Klarna In-Store Digital Card in the US . We are working to restore the service as soon as possible. Thank you for your patience.
Posted Nov 09, 2023 - 02:38 CET
This incident affected: Klarna App (North America).