External bureau degradation in Finland
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Jul 02, 2024 - 13:59 CEST
Identified
The bureau has acknowledged the outage and is investigating how to mitigate it. The status page of the provider where progress can be followed: https://status.dnb.com/
Posted Jul 02, 2024 - 11:50 CEST
Investigating
We are currently experiencing issues with an external bureau in Finland region. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Jul 02, 2024 - 11:46 CEST
This incident affected: Purchase API (Europe) and Klarna App (Europe).