Direct Debit is experiencing issues in Austria, Germany and Netherlands

Incident Report for Klarna

Resolved

This incident has been resolved.
Posted Aug 25, 2026 - 14:58 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 25, 2026 - 14:58 CEST

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 25, 2026 - 14:50 CEST

Investigating

We are currently experiencing a Direct Debit payment method degradation in the Austria, Germany and Netherlands regions. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Aug 25, 2026 - 14:30 CEST
This incident affected: Payments in the App (Europe, North America, Asia Pacific).