KCO Issues
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Oct 08, 2024 - 21:34 CEST
Investigating
We are currently experiencing intermittent issues with KCO in EU. We are currently investigating this problem and will provide further updates when available.
Posted Oct 08, 2024 - 16:33 CEST