Possible double charges on card payments with Visa cards in EU
Incident Report for Klarna
Resolved
Our 3rd party provider has confirmed that the transactions that were duplicated are reversed.

When the cardholders see this, that depends on how quickly and frequently issuers upload their incoming files from VISA.

We apologize for any inconvenience caused.
Posted Sep 09, 2021 - 12:13 CEST
Update
Our 3rd party payment service provider is working on correcting this as a matter of importance and aims to have this completed and visible to the cardholders today.
Posted Sep 08, 2021 - 10:14 CEST
Investigating
Due to a 3rd party payment service provider, card payments made with Visa cards in the EU on Sept 6th, may result in 2 charges. Our service provider is working on correcting the issue and remove the 2nd charge. We apologize for the inconvenience.
Posted Sep 07, 2021 - 16:54 CEST