Delayed SEK payouts through Nordea for merchants
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Jan 04, 2022 - 09:30 CET
Investigating
Merchants who receive SEK payouts through Nordea might experience delays in their payouts. We apologize for the delay and thank you for your patience.
Posted Dec 30, 2021 - 12:01 CET
This incident affected: Merchant Operations (Europe).