Klarna Disputes App degradation in EU, US, and AP
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Apr 19, 2023 - 13:11 CEST
Investigating
We were experiencing a degradation of Disputes App in EU, US, and AP between 12:10 and 12:50 CET. Service is now restored. Thank you for your patience.
Posted Apr 19, 2023 - 13:10 CEST
This incident affected: Klarna App (Europe, North America, Asia Pacific).