Merchant Portal degradation
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Sep 11, 2024 - 13:35 CEST
Update
We are continuing to investigate this issue.
Posted Sep 11, 2024 - 10:24 CEST
Investigating
We are currently experiencing issues with the Merchant Portal and our operations might be delayed. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Sep 11, 2024 - 10:15 CEST
This incident affected: Merchant Operations (Europe, North America, Asia Pacific).