Klarna App degradation
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Jun 07, 2024 - 08:48 CEST
Update
We are continuing to investigate this issue.
Posted Jun 07, 2024 - 08:48 CEST
Investigating
We are currently experiencing issues with the login via OTP SMS feature in Finland. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Jun 06, 2024 - 14:36 CEST
This incident affected: Klarna App (Europe).