Customer support chat degradation
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Mar 17, 2023 - 07:48 CET
Investigating
We are currently experiencing a degradation of Klarna Support for chat in the US since 06:40 CET. Please use mail or phone as an alternative to reach us for support. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Mar 17, 2023 - 07:36 CET
This incident affected: Support (North America).