US merchants are unable to submit requests to change their bank account details
Incident Report for Klarna
Resolved
This incident has been resolved. We apologize for the inconvenience.
Posted Aug 18, 2021 - 21:08 CEST
Monitoring
Technical teams have applied a fix and are monitoring the results at this time.
Posted Aug 18, 2021 - 19:43 CEST
Investigating
Merchants are currently not able to submit requests to change their bank account details through merchant portal in the US.
We are currently investigating the issue and apologize for the inconvenience.
Posted Aug 18, 2021 - 16:38 CEST
This incident affected: Merchant Portal.