iDeal availability issues
Incident Report for Klarna
Resolved
The external availability issue is now resolved.
Posted Mar 24, 2020 - 17:48 CET
Investigating
Due to an external issue, the banks SNS, ASN and RegioBank in the iDeal Network in the Netherlands are experiencing availability issues. Therefore, the customers of these banks are not able to start alternative payments.
For more information about the iDeal availability, please visit https://availability.ideal.nl/
Posted Mar 24, 2020 - 16:40 CET
This incident affected: Klarna App and Klarna Checkout (KCO).