US Account Welcome emails inadvertently sent to already existing customers
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted 2 months ago. May 21, 2019 - 18:25 CEST
Identified
Due to a system misconfiguration, already existing US Account customers might inadvertently have received a new Welcome email. This is currently being investigated.
Posted 2 months ago. May 17, 2019 - 18:28 CEST