Merchant payouts delayed for GBP
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted May 13, 2022 - 17:24 CEST
Update
We are still investigating the issue with our third-party provider. We apologize for any inconvenience caused during this time.
Posted May 10, 2022 - 18:09 CEST
Investigating
We are still investigating the issue with our third-party provider. We apologize for any inconvenience caused during this time.
Posted May 06, 2022 - 13:03 CEST
Identified
Merchants being settled in GBP may experience a one-day delay in payouts. We are working to restore the payments as soon as possible. Thank you for your patience.
Posted May 03, 2022 - 19:12 CEST
This incident affected: Merchant Operations (Europe).