Switzerlands merchants not able to complete orders
Incident Report for Klarna
Resolved
Our engineers have resolved this problem and normal service is resumed. We thank you for your patience and apologize for the inconvenience caused. If you encounter any further trouble in relation to completing orders, please reach out to your technical account manager for further assistance.
Posted Aug 17, 2020 - 14:45 CEST
Monitoring
Order completion is working as expected. We are continuously monitoring the situation.
Posted Aug 17, 2020 - 14:29 CEST
Investigating
Merchants in Switzerlands are currently experiencing difficulties completing orders. Our engineers are investigating the issue and we apologize for the inconvenience caused. We will provide further updates as soon as possible.
Posted Aug 17, 2020 - 13:59 CEST
This incident affected: Klarna Payments (KP).