Przelewy24 payment method disturbance in Poland

Incident Report for Klarna

Resolved

This incident has been resolved.
Posted Jun 22, 2022 - 23:10 CEST

Update

We are starting to see improvements but the maintenance is still ongoing. We will continue to monitor until the scheduled end (11 PM CEST).
Posted Jun 22, 2022 - 20:43 CEST

Monitoring

We have identified that this is due to scheduled maintenance on our 3rd party provider's side until 11 PM CEST. We will continue to monitor the service.
Posted Jun 22, 2022 - 18:48 CEST

Investigating

We see a degradation of payment method Przelewy24 in Poland. This is impacting payments in the Klarna App. We are monitoring.
Posted Jun 22, 2022 - 18:20 CEST
This incident affected: Klarna App (Europe).