Issues with several Klarna payment methods in the EU
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Nov 04, 2021 - 18:10 CET
Investigating
Due to a technical error, customers may be experiencing difficulties in making purchases with Klarna Check Out. We are researching the issue at the moment. We are sorry for any inconvenience this is causing.
Posted Nov 04, 2021 - 16:49 CET