Frontend in Settlements App - merchant portal is currently down.
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted 5 months ago. Mar 28, 2019 - 19:27 CET
Update
Issue concerns the Settlements app, not the entire Merchant Portal
Posted 5 months ago. Mar 28, 2019 - 18:01 CET
Identified
Affecting EU and US. The cause of this is already identified and a rollback is under way.
Posted 5 months ago. Mar 28, 2019 - 17:55 CET
This incident affected: Merchant Portal.