Consumers in EU are unable to authenticate using ID Scan
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Mar 04, 2024 - 13:05 CET
Investigating
Due to a problem with ID Scan, login and purchase authentication using ID Scan is currently degraded.
Posted Mar 04, 2024 - 12:30 CET
This incident affected: Klarna App (Europe).