Klarna App degradation

Incident Report for Klarna

Resolved

This incident has been resolved.
Posted Jul 24, 2023 - 14:51 CEST

Investigating

We are currently experiencing issues with the Search in Klarna App in EU and US. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Jul 24, 2023 - 14:36 CEST
This incident affected: Klarna App (Europe, North America, Asia Pacific).