Klarna purchase flow degradation for some b2b orders

Incident Report for Klarna

Resolved

Service has been restored. Thank you for your patience.
Posted Mar 14, 2025 - 14:26 CET

Investigating

We are currently experiencing issues with Klarna purchase flow for some b2b orders in Europe. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Mar 14, 2025 - 13:27 CET