Klarna Card Sign up not possible during maintenance
Incident Report for Klarna
Resolved
The maintenance is over and the sign up is enabled again.
Posted 14 days ago. Aug 07, 2019 - 15:58 CEST
Investigating
Due to a scheduled maintenance we have already disabled the Klarna Card Sign up in SE and DE for web and native for about 40 mins.
We will inform you as soon as the sign up is available again.
Posted 14 days ago. Aug 07, 2019 - 14:50 CEST
This incident affected: Klarna Card.