Klarna Card degradation

Incident Report for Klarna

Resolved

This incident has been resolved.
Posted Mar 18, 2025 - 15:21 CET

Investigating

We are currently experiencing issues with Klarna Card and Klarna Balance in EU and US. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Mar 18, 2025 - 14:16 CET
This incident affected: Klarna Card (Europe, US).