EU consumers not able to complete orders with cards
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Oct 21, 2020 - 00:20 CEST
Monitoring
The 3rd party provider has resolved the issue on their side. Our teams are monitoring the situation to ensure the issue is resolved on our side as well.
Posted Oct 20, 2020 - 21:08 CEST
Identified
Due an issue with a 3rd party, consumers are currently experiencing difficulties making purchases with cards at this time. We will provide further updates as soon as possible.
Posted Oct 20, 2020 - 17:57 CEST