Performance degradation for Klarna Payments in EU
Incident Report for Klarna
Resolved
The issue is fully resolved. We will continue monitor the situation closely throughout the weekend.
Posted Nov 26, 2020 - 19:55 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 26, 2020 - 19:28 CET
Update
We have observed a 30% degradation in placed orders within the EU between 17:54 and 18:20 (CET). We are continuing to evaluate the effect of this incident and will provide further updates in due course.
Posted Nov 26, 2020 - 19:27 CET
Investigating
We are currently investigating the issue and apologize for the inconvenience caused. We will update as soon as we have more information.
Posted Nov 26, 2020 - 18:51 CET
This incident affected: Klarna Payments (KP).