Merchant payouts delayed for UK (GBP)

Incident Report for Klarna

Resolved

This incident has been resolved.
Posted Oct 17, 2023 - 22:47 CEST

Investigating

Merchants being settled in UK (GBP) may experience a one day delay in payouts. We are working to restore the payments as soon as possible. Thank you for your patience.
Posted Oct 17, 2023 - 12:30 CEST