Problems with Klarna App sign up in Australia
Incident Report for Klarna
Resolved
The issue has been resolved. The sign-up works as intended again.
Posted May 06, 2020 - 10:59 CEST
Investigating
Australian customers might currently see an error message when signing up for the Klarna App. Our engineers are investigating the issue and we apologize for the inconvenience caused. We will provide further updates as soon as possible.
Posted May 06, 2020 - 09:54 CEST
This incident affected: Klarna App.