Refunds for German Klarna Card users handled manually
Incident Report for Klarna
Resolved
We have now resolved the issue and refunds are not delayed anymore.
Posted 3 months ago. May 24, 2019 - 17:14 CEST
Identified
There is currently an issue with refunds for German customers who use the "Pay Later" payment method for their Klarna Card.
A fix is on it's way but for the moment refunds for affected customers are being handled manually meaning some users may experience delays.
Posted 3 months ago. May 24, 2019 - 14:36 CEST
This incident affected: Klarna Card.