Banking Service degradation in Germany and Sweden.

Incident Report for Klarna

Resolved

This incident has been resolved.
Posted Sep 20, 2023 - 17:43 CEST

Investigating

We are experiencing issues with Banking Services, which may impact Customers ability to access their bank/savings account and use their debit card. We working on correcting at this time. We apologize for the inconvenience.
Posted Sep 20, 2023 - 17:06 CEST