Klarna Card degradation
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted May 13, 2022 - 12:10 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted May 13, 2022 - 11:35 CEST
Investigating
We are currently experiencing issues with Klarna Card in the EU . We are working to restore the service as soon as possible. Thank you for your patience.
Posted May 13, 2022 - 10:31 CEST
This incident affected: Klarna Card (Europe).