Several failing services cause issues with the Klarna App
Incident Report for Klarna
Resolved
The failing services in our Klarna App are back and working again. We apologize for any inconvenience.
Posted 18 days ago. Jul 03, 2019 - 14:30 CEST
Investigating
Due to several issues with our Klarna App services, consumers might not be able to see their orders. We're already working on a solution and will send further information as soon as we can.
Posted 18 days ago. Jul 03, 2019 - 13:25 CEST
This incident affected: Klarna App.