Merchant Portal degradation
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Apr 28, 2022 - 15:09 CEST
Investigating
We are currently experiencing a degradation of the chat function in the Merchant Portal. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Apr 28, 2022 - 15:06 CEST
This incident affected: Merchant Operations (Europe, North America, Asia Pacific).