Service disruption for https://app.klarna.com/login
Incident Report for Klarna
Resolved
The issue has now been resolved.
Posted Feb 06, 2020 - 20:27 CET
Investigating
We are currently experiencing service disruption.
Our engineers are already working on this. We will send an update as soon as we can and we apologise for any inconveniences.
Posted Feb 06, 2020 - 20:02 CET
This incident affected: Klarna App.