We are currently experiencing issues with our communication tools which results in customers not being able to call or chat with our customer/merchant services.
Incident Report for Klarna
Resolved
This incident has been resolved.
Posted Jul 13, 2021 - 16:02 CEST
Investigating
Due to technical issues, it can be difficult to reach our customer/merchant service by chat or phone. We are working on solving this issue as soon as possible and apologize for any inconvenience caused
Posted Jul 13, 2021 - 14:42 CEST
This incident affected: Customer Service.