Customer service degredation

Incident Report for Klarna

Resolved

This incident has been resolved.
Posted Nov 16, 2022 - 10:18 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 16, 2022 - 10:12 CET

Update

We are still working on restoring the service fully.
Posted Nov 16, 2022 - 09:49 CET

Investigating

We are currently experiencing technical issues with our customer service. Customer service is still reachable both through chat and phone. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Nov 16, 2022 - 08:52 CET
This incident affected: Support (Europe, North America, Asia Pacific).